Enabling PDF Content Crawling

Overview

Sometimes, customers may want to search for the PDF files and their content on their DNN sites. By default, PDF content crawling is not enabled and you will need to install the Adobe iFilter to enable content crawling for the .PDF file extension.

 

Prerequisites

  • Administrator rights on the operating system where the DNN instance is installed
  • Superuser access to the DNN site

 

Diagnosis

To be able to search for PDF contents, you would need the PDF Filter installed. For further details related to the Adobe iFilter, refer to the Adobe resources and Adobe PDF iFilter.

You can check if the PDF Ifilter is installed by going into Settings > Site Settings > Search > File Extensions and check the .pdf file extension. This should have a checkmark if it is enabled.

 

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Solution

  1. Download and install the PDF iFilter. Install PDF iFilter 64 v11.0.01 on the server hosting the DNN site.

  2. Once installed, navigate to the Persona Bar > Settings > Site Settings > Search > File Extensions. Here, you will find the PDF Filter enabled for content crawling, as shown in the image below.

    File.Extensions.png

     
  3. Navigate to the Persona Bar > Settings > Scheduler > Scheduler tab.

  4. Now, you must force run three (3) scheduled tasks to index the site again. These tasks are File, Site, and URL Crawlers. For each of these tasks, click the pencil icon to edit it and click Run Now.

 

Additional Information

  • Content Crawling will not be enabled in your application pool if it does not match the bit parity of the PDF iFilter you are installing.

    Check the advanced settings for your application pool and browse to the Enable 32-Bit Applications setting. For an x64 bit IFilter, the setting must be set to False.

    2020-03-11_1031.png

     
  • If you would like to enable deep content crawling for compressed PDF files only, we recommend the use of iFilter v6. The following grid shows the test results of using various iFilter versions for compressed PDF files:

    Version Result
    iFilter v11 Crashes
    iFilter v9 Only does a shallow index
    iFilter v6 Deep indexes without errors 

 

Testing

Once all three (3) scheduled tasks have run successfully:

  1. Go to the Search Results page.
  2. Search for a keyword that is inside the PDF.
  3. The keyword should appear in the results.

Note: If the changes do not take effect after all 3 scheduled tasks have run, perform a site re-index for the changes to take effect. Please remember a re-index should not be done during peak hours to avoid performance issues on the site.

 

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