Connecting Google analytics shows temporarily disabled sign in

Overview

Attempting to connect the Google Analytics connector causes the error "Sign in with Google temporarily disabled for this app" to be displayed.

 

Diagnosis

Currently, the Google Analytics Service app is in the "unverified" state which imposes 100 new-user quota limits as a result the Evoq Google Analytics connector will not accept new customer connections, instead displays the below error page.

mceclip0.png

 

Solution

The long term resolution to this problem is this application being verified, by engineering.

As a temporary workaround, we can add the standard google analytics script to each page by following the instructions below.

  1. Navigate to Settings>Site Settings>Site Behavior>Default Pages
  2. Add the following Code Snippet to HTML Page Header Tags
    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

      ga('create', 'UA-###########', 'auto');
      ga('send', 'pageview');

    </script>
  3. Replace UA-########### with the Google Analytics Tracking ID you can find by logging onto google analytics, Clicking Admin, Then under Property click Property settings and copy the tracking ID.

This will restore some functionality to the Google Analytics dashboard.

 

Comments

0 comments

Please sign in to leave a comment.