Overview
- This article shares multiple resolutions to fix this issue when the internet is working fine, but the Site Setting menu throws the following error:
There was an error retrieving your content. Please check your internet connection. - Important Note: If you are unsure about securely performing the steps mentioned in this article, always make a backup before making any changes or reach out to support for more help.
Environment
DNN 9.x
Requirements
Host access or DB Access to check and correct the affected tables.
Resolution 1
- Root Cause:
- In DNN 9.0 when deleting a Portal Alias, any reference to the same
PortalAliasID
should also be removed from theTabUrls
table. - When a reference to a non-existing
PortalAliasId
, is left in theTabUrls
table, the Page Setting page will not load correctly.
- In DNN 9.0 when deleting a Portal Alias, any reference to the same
- Process:
- This issue is resolved in DNN 9.2.
- Deleting or updating the reference to the non-existing
PortalAliasID
from theTabUrls
table will resolve this issue. Follow these steps:
- Access PB > Settings > SQL Console or DB access via SSMS.
- From the affected page settings tab, identify the TabId. This can also be done from the DB with the following query:
SELECT *
FROM tabs
WHERE tabname LIKE '%name_of_affected_page%'; - Once the TabId has been identified, search for the tab aliases defined for that page and compare with the
PortalAliasId
available for the site with these two queries:
SELECT *
FROM taburls
WHERE TabId=<TabId>;and
SELECT *
FROM PortalAlias; -
Cross-reference the
PortalAliasId
field from both queries. AnyPortalAliasId
fromTabUrls
table should also exist in thePortalAlias
table. -
In case of an invalid entry in the
TabUrls
table, the invalidPortalAliasId
can either be set toNull
or updated to an existingPortalAliasId
.
Resolution 2
- Root Cause:
- In addition to the error noted above, the following general exception is logged in the stack trace:
AbsoluteURL /API/PersonaBar/EvoqPages/GetPageDetails DefaultDataProvider D
AbsoluteURL:/API/PersonaBar/EvoqPages/GetPageDetails
DefaultDataProvider:DotNetNuke.Data.SqlDataProvider, DotNetNuke
ExceptionGUID:ad6bcf1a-f201-4270-abbf-6005cae6c88a
AssemblyVersion:
PortalId:-1
UserId:-1
TabId:-1
Message: Object reference not set to an instance of an object.
PortalAliasId
column inTabUrls
table consists of value "1", by default this should be NULL instead.
- In addition to the error noted above, the following general exception is logged in the stack trace:
- Process:
- Please follow the steps below:
- Find the problematic entry in the
TabUrls
table by executing the SQL query below:SELECT * FROM TabUrls WHERE PortalAliasId IS NOT NULL
- Take note of the TabId and SeqNum of the problematic row that needs to be modified.
- Execute the following SQL query to fix the problematic entry.
UPDATE TabUrls SET PortalAliasId = NULL Where TabId = <Enter TabId from Step 2> AND SeqNum = <Enter SeqNum from Step 2>
- Find the problematic entry in the
- Refresh the Cache, restart the application pool and restart DNN.
- Please follow the steps below:
Resolution 3
- Root Cause:
- A number of Aliases added to the site URLs because the customer has the Auto-Add Site Alias option enabled.
- The older aliases are coming from site migration, or from URLs which are no longer active or have been removed.
- Process:
- Log into your DNN Site and follow the steps below:
- Go to Persona Bar > Site Settings > Site Behavior tab.
- Click on Site Aliases Tab.
- Verify all site aliases are added correctly.
- Each alias should correspond to an URL that is actively used to navigate to this site.
- Remove any alias that is no longer in use.
- If enabled, please disable the Auto-Add Site Alias option on the same page.
-
For versions prior to DNN 9.x follow these steps:
- Once logged in, from the Control Bar, go to Admin > Common Settings > Site Settings.
- Click on the Advanced Settings tab > expand Site Aliases node.
- Verify all the site aliases are added correctly.
- Each alias should correspond to a URL that is actively used to navigate to this site.
- Remove any alias you are no longer using, if any.
- If enabled, please disable the Auto-Add Site Alias option on the same page.
- Log into your DNN Site and follow the steps below:
Resolution 4
- Root Cause:
- Reviewing logs and the user finds an additional error:
No sub-file with id _2h9o.fdt found - This file should be located under SiteDirectory\App_Data\Search.
- Reviewing logs and the user finds an additional error:
- Process:
- Follow these steps below to resolve this issue:
- Force run the three crawlers below:
- Search: File Crawler
- Search: Site Crawler
- Search: Url Crawler
- Back up the entire "Search" folder, then delete it trying to force all three crawlers one more time.
- This is an alternative way to force-reindexing contents since we cannot access it through the Basic Settings tab.
- Restart the application.
- Force run the three crawlers below:
- Follow these steps below to resolve this issue:
Confirmation
- After executing this change, go to Settings > Servers > Clear Cache in order to load the new settings from the database.
- Try to load the settings page again.
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