Overview
The following error occurs after an upgrade while accessing the Users menu in the Persona Bar:
Procedure or function 'Personabar_GetUsersBySearchTerm' expects parameter '@HasAgreedToTerms', which was not supplied.
The following message is seen in the log file located in the Portals/_default/Logs folder:
Error executing SQL: ;Exec dbo.Personabar_GetUsersBySearchTerm @0, @1, @2, @3, @4, @5, @6, @7, @8
Procedure or function 'Personabar_GetUsersBySearchTerm' expects parameter '@HasAgreedToTerms', which was not supplied.
2020-01-14 09:14:19.681-05:00 [WEB02][D:2][T:22][ERROR] Dnn.PersonaBar.Users.Services.UsersController - System.Data.SqlClient.SqlException (0x80131904): Procedure or function 'Personabar_GetUsersBySearchTerm' expects parameter '@HasAgreedToTerms', which was not supplied.
Prerequisites
- Access to a SuperUser account.
Diagnosis
The error mentioned in the Overview section is caused by a failure in the upgrade that was performed where an SQLDataProvider file was not executed to update the stored procedures in the SQL database. The error occurs because of a parameter named @HasAgreedtoTerms
that does not exist in the current stored procedure.
Solution
Restoring the installation with a backup and re-performing the upgrade resolves this issue.
Make sure you follow all the steps defined in the upgrade guide.
Testing
- Log into a SuperUser account
- Go to Manage > Users and try to see the log file located in the Portals/_default/Logs folder
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