Overview
When you upload an asset through a Form Builder Asset component and click on the View in Assets link after browsing the responses, the function does not work.
Prerequisites
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Versions Evoq 9.4.3 and lower
- Access to a SuperUser Account
Diagnosis
The described issue is a known bug with a code in the Evoq 9.4.3 and below versions. This is caused by the fact that assets that are uploaded via Form Builder are not stored locally. The View in Assets link throws an error since it is trying to return a folder that does not exist and was never meant to be shown in the UI.
This can be reproduced by:
- Going to Content > Forms
- Access a Form with an upload asset field
- Upload an image file
- Then browse to the specific form and view the responses
Solution
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The solution is to upgrade your environment to Evoq 9.4.4.
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You can download the upgrade packages here: DNN CMS & Online Community Software while logged in as a user account.
Testing
- When you browse to Content > Forms > Specific Form's Responses > The View in Assets link should be now hidden from view.
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