Overview
Google Analytics tracks all site requests and displays reporting in the form of charts and graphs. There is an issue where Google Analytics will stop tracking site data after a period of time even though the Google Analytics connector is connected.
Prerequisites
- Access to a SuperUser/Host account.
Diagnosis
This can occur if one or more Google Analytics settings have been changed since initial setup, or if the Google Analytics script has been edited. Evoq will not include a Google Analytics script in your site's pages if the script contains invalid values.
You can verify that Google Analytics has stopped tracking data by going to Dashboard > Site Analytics or Page Analytics in the Persona Bar.
Solution
- Go to Persona Bar > Settings > Connectors.
- Under Configure Connections, locate Google Analytics row and click Edit.
- Confirm that Account, Web Property, and Profile settings match the Google account you intend to use, the site you intend to collect data for, and the data collection profile you intend to use.
- Click the gear icon to access Advanced Settings.
- Confirm that Domain Name is set correctly. This setting is used to exclude a domain from being counted as an external referral. Leave this setting blank for Google Analytics to operate without cross-domain tracking. Note that Evoq will not load Google Analytics scripts on your pages if an invalid value is set for Domain Name.
- Save after making any changes.
Testing
You can test that this issue has been resolved by:
- Access any page of the site
- Log into your SuperUser account and go to the page that you've accessed
- Click Page Analytics
You should be able to see traffic from the request that you've made from your test.
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