Overview
After a DNN environment is upgraded to version 9.0.0 or later, multiple users report that buttons, Persona Bar menu items, or other elements from the user interface are missing. This happens regardless of the user's role and permissions.
Prerequisites
- Versions below Evoq 9
- Access to a SuperUser account
Diagnosis
This problem can result from having more than one Content Page Template tab for a single portal. Follow the steps below to find any duplicate Content Page Template tabs and delete them.
Caution: back up the database and site directory before making any changes.
Solution
- Go to Settings > SQL Console > Run the following query to find which of your portal's tabs are Content Page Templates.
SELECT * FROM Tabs WHERE TabName = 'ContentPageTemplates'
- Run the following query to see if any of the Content Page Templates have no child pages. Replace the example values "123" and "987" below with the results from step 1.
SELECT * FROM Tabs WHERE ParentID IN (123, 987)
- Delete the template(s) with no child pages using the query below. Replace the value "987" below with the actual tab IDs of templates that have no child pages. The example below represents the proper query to use if the query in step 1 returned the values "123" and "987", and the sample query in step 2 found that 123 had child pages and 987 did not.
DELETE FROM Tabs WHERE TabID = 987
- Go to Persona Bar > Servers and click Clear Cache and Restart Application.
- Refresh the page in the browser by using CTRL+F5 to do a hard refresh.
This should restore the missing user interface elements.
Testing
To test that this has been resolved:
- Login as a SuperUser
- Try to access the Persona Bar
You should be able to access any Persona Bar items.
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