Issue
When attempting to set up localization options for customers, users are able to see the localization flags and click on them for the translated pages when logged in as an admin. After logging out, the localization flags are no longer visible to select.
Root Cause
The localization flags are not showing when logged out because the localized pages have not been published yet. As with all pages, admins are able to see the layout in 'draft mode,' whereas regular users/visitors are not.
Resolution
Requirements: Admin access to the DNN portal
1. Log in to DNN with admin credentials.
2. Go to Persona Bar > Settings > Site Settings.
3. Click on the Languages tab and then the localized pages icon for a language.
4. On the next screen, click on the Publish All Pages button.
If successful, the following message will pop up:
5. Repeat Steps 3 and 4 for the appropriate languages.
6. Validate the fix by logging out. You will now see the language flags on the pages and be able to select them as intended.
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