Embedded DNN Forms in external sites are failing to send email notifications

Overview

This article aims to resolve an issue when an embedded form on an external site fails to send the email notifications when it is submitted even though the other forms on the master site may send the notifications successfully.

 



Prerequisites

 


 

Diagnosis

Embedded forms placed in external sites do not send any notifications for submissions because the email is handled by the application itself (DNN), and not by the Microservices. This means that once you run the form anywhere else outside of its master site, it will not include the sendemail string that is required to push the notifications.

This a known functionality in Evoq 9.1.1 and newer versions that prevent a form from sending the notifications if that form is added to the page using the Embed Code option inside an HTML Pro Module.

 


 

Solution 

As of now, this is intended functionality where an embedded DNN form is unable to send email notifications of form responses as there was no mechanism created to send email notifications from an external site. This has been looked at as an enhancement to be implemented in the future. You will need to refrain from using form notifications for embedded forms on external sites.

If you are using the embedded forms in the master site, you should insert the form on the page as a Forms module.

 

Comments

0 comments

Please sign in to leave a comment.