Overview
Even though it has been enabled, the scheduled task does not appear to be executing after viewing the Schedule history. This article explains why the scheduled task is not running.
Prerequisites
- These instructions are for DNN version 9+.
- You need to log in as a host user.
Diagnosis
The reason why the scheduled task is not executing is that the server name is not defined in Setting > Scheduler > Scheduler > Edit Scheduled Task > Server Name. A scheduled task needs to be running on a specific server and if a server name is defined but is not part of your current server group due to orphaned data, you will need to change it to blank or a specific server depending on your server environment.
Solution
- Log in as a host user.
- Click Settings in Persona Bar.
- Click Scheduler.
- Click Scheduler Tab.
- Click Edit button against scheduler in question.
- For a single server environment - verify that Servers text field is blank. The Scheduler will detect the server automatically.
- For a web farm environment - input specific Server name the scheduler needs to run on.
- You can check which servers are currently enabled on your site in Settings > Servers > Server Settings > Web Servers
- For a single server environment - verify that Servers text field is blank. The Scheduler will detect the server automatically.
Testing
Confirm that the scheduler is running by:
- Go to Settings > Scheduler > Scheduler > Edit Scheduled Task > Click Run Now
- Go to the Schedule History for this task and try to see if the task has executed.
Comments
1 comment
Can you please update the same for previous version 05.06.07(7) . My scheduler stopped working and in history it shows success false.
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