Overview
When you would like to export and import a copy of Liquid Content into another environment without exporting any other data, you need to use Import/Export. This process will take all the Liquid Content data and provide the ability to easily import the data into another server.
Prerequisites
- SuperUser/Host or admin access.
Diagnosis
Liquid Content is wholly stored within the shared DNN cloud infrastructure and is connected to individual DNN instances through the use of microservices. Because the nature of the cloud infrastructure is that many DNN instances are connected and utilizing the service, it can be difficult to roll-back to a previous cloud snapshot to recover deleted data. For this reason, it's important to create locally accessible Liquid Content backups as a routine part of site maintenance.
Solution
1. Log in to your DNN instance with SuperUser/Host or admin credentials.
2. Go to Settings > Import/Export.
3. Use the Site drop-down at the top of the screen to select the site you want to backup.
4. Click Export Data.
5. On the Export Settings page, enter a name for the export file. It's advisable to also add the date of the export unless you plan to overwrite the backups on each run.
5. Turn off all assets for export except Content Library.
6. Make sure Run Now is set to on.
7. Click Begin Export.
8. The following message will show and you should see the In Progress icon under Status in the background:
9. If successful, the status will display completed.
Testing
Validate that the files have been backed-up successfully by going to your website's SiteRoot/App_Data/ExportImport folder on your server. You will see a sub-folder for each backup run.
Comments
2 comments
How can you automate this process?
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