Upgrading to 9.0 or above breaks the text and image editor

Overview

To ensure the HTML editor within DNN is functioning properly.

Requirements

Superuser access

Issue

After an EVOQ upgrade to 9.0 or above, the UI of the text and image editor is corrupted, rendering it unusable:

brokeneditor.jpg

Environment: EVOQ upgraded from a version prior to 9.0 to a version 9.0 or above. 

Root Cause

Due to the deprecation of Telerik starting in versions 9.0 of EVOQ, the editor seen above (known as RadEditor) will no longer work as it is dependent on Telerik.  

The legacy version of the HTML editor is not supported in some of the later versions of DNN

Resolution

In versions 9.0 and above, we are now using CKEditor so you will need to make this change in your EVOQ instance. 

Download and Install the CKEditor module from the DNN Software website.

1. Log in to your EVOQ instance with a SuperUser/Admin account. 

2. On your Persona Bar, go to Settings > Site Settings

sitesettings.jpg

3. Click on the Site Behavior tab.

4. Click on the More sub-tab.

5. Click on Open HTML Editor Manager.

htmleditor.jpg

6. On the following page, use the drop-down to select DNNConnect.CKE and click Change.

CKEditor.jpg

7. Validate the change by navigating to a page within your DNN instance in Edit Mode and clicking on an image or text resource to see the editor. 

neweditor.jpg

 

Content Author: Corey Tedder

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