Renewed License hasn't been Updated on the Frontend

Issue

License has been extended but it hasn't been renewed on the system frontend and there is no renew button against the license in question to update it. This means that expiration date hasn't been extended and there is a risk of downtime. If activation has already expired or you can use a maintenance window - you can just remove the old record and activate your license again. Workaround without downtime requires to add the same license again as dev type (Note: This is only allowed for a very short period of time), removal of the old record, activation, and removal of dev license.

 

Root Cause

Miscommunication between frontend installation and licensing backend. This may happen because of various reasons, including network issues. Most of the time, it is easier to complete these workarounds than to investigate further. 

 

Solution 1 (With Downtime)

  1. Click Settings in the Persona Bar.
  2. Click About.

  3. Confirm that there is no renew button against your license in question (If there is one you - can renew expiration date using this button).
  4. Click Remove button against the license in question and confirm removal (downtime starts at this step).
  5. Click Add License.


  6. Select Production from the License Type drop-down list.
  7. Enter Account Email in the corresponding text field.
  8. Enter Invoice Number associated with your license in the corresponding text field.
  9. Click Automatic Activation (downtime ends at this step).

Confirmation: EXPIRES column should be updated with the correct expiration date for your valid production license.

Solution 2 (Without Downtime)

Note: Using a development license type on a production instance is only allowed for a very short period of time and only in exceptional circumstances.

  1. Click Settings in the Persona Bar.
  2. Click About.

  3. Confirm that there is no renew button against your license in question (If there is one you - can renew expiration date using this button).
  4. Click Add License.

  5. Select Development from the License Type drop-down list.
  6. Enter Account Email in the corresponding text field.
  7. Enter Invoice Number associated with your license in the corresponding text field.
  8. Click Automatic Activation.

  9. Click Remove button against the license in question (production type) and confirm removal.
  10. Click Add License.
  11. Select Production from the License Type drop-down list.
  12. Enter Account Email in the corresponding text field.
  13. Enter Invoice Number associated with your license in the corresponding text field.
  14. Click Automatic Activation.
  15. Click Remove button against the development license and confirm removal.

Confirmation: EXPIRES column should be updated with the correct expiration date for your valid production license.

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