Troubleshooting: Incomplete Localization

Troubleshooting: Incomplete Content Localization

  • Platform
  • Evoq Content
  • Evoq Engage

Symptom

After enabling localization, only some content is localized.

Possible Cause

The localization process timed out during the conversion.

Solution

  1. Back up the site and the database.
  2. Go to Persona Bar > Settings > SQL Console.
  3. Delete the culture code of the aborted localization process.
    Run the following SQL script:
    
    DELETE
    FROM Tabs
    WHERE CultureCode = 'xx-XX';
                                
    where xx-XX is the culture code of the added language.
  4. Disable content localization for the site.
    Run the following SQL script:
    
    UPDATE Tabs
    SET CultureCode = NULL;
    
    UPDATE PortalSettings
    SET SettingValue = 'False'
    WHERE SettingName = 'ContentLocalizationEnabled'
    	AND PortalID = xx;
                                
    where xx is the ID of the site for which localization was enabled.
  5. Recycle the application pool to allow the changes to take effect.

  6. Rerun the localization process.

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