DNN System Requirements

The following are required for DNN Platform 9.4 and DNN Evoq 9.4.

Supported Operating Systems

  • Windows 8
  • Windows 8.1
  • Windows 10
  • Windows Server 2008 R2
  • Windows Server 2012 R2
  • Windows Server 2016

.NET Framework

  • 4.7.2+

Web Server

  • Microsoft IIS 7.5, 8.0, 8.5, 10

Database Server

  • Microsoft SQL Server 2008 R2
  • Microsoft SQL Server 2008 Express R2
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2012 Express
  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2014 Express
  • Microsoft SQL Server 2016 (for DNN 8.0.4+)
  • Microsoft Azure SQL Database

Browsers

  • Chrome
  • Firefox
  • IE 11
  • Microsoft Edge
  • Safari for Mac
Note: DNN products are tested on the latest browser versions at the time of release. Although untested, older browsers could still work.

Developer IDEs

For creating extensions:

  • Visual Studio 2015
  • Visual Studio 2017
  • Visual Studio 2019
Note: Starting with DNN 9.4.0, .NET Framework 4.7.2+ is required, however, it is still possible to use older versions of Visual Studio, and .NET Framework for extension development. The minimum version for extension development is dependent upon the targeted DNN Minimum Version.


For contributing to the DNN Platform:

  • Visual Studio 2017
  • Visual Studio 2019

Recommended Environment

  • Windows Server 2012 R2
  • IIS 8.5
  • SQL Server 2014 or Later
  • For developers: SQL Server 2014 Developer Edition or Express
  • For developers: Visual Studio 2019

Comments

1 comment

  • Avatar
    Alberto Troiano

    Hello.

    Windows Server 2019 is not listed as supported. I tried and I had no troubles. In fact, DNN Version 9.6.1 installs smoothly in an out of the box installation of WSrv 2019 since it already comes with .NET4.7 installed.

    0
    Comment actions Permalink

Please sign in to leave a comment.