Overview
When upgrading to Evoq 9.10.0 or above, you see the persona bar load but it does not contain any icons
Diagnosis
Load your DNN Site and confirm the persona bar is missing all icons
Your DNN logs will show the following error:
[ERROR] DotNetNuke.Web.DependencyInjectionInitialize - Unable to configure services for DotNetNuke.Professional.DigitalAssets, Version=9.0.0.870, Culture=neutral, PublicKeyToken=null, see exception for details
- LoaderException: Could not load file or assembly 'DotNetNuke.Modules.DigitalAssets, Version=9.0.0.1, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.
System.Reflection.ReflectionTypeLoadException: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
at System.Reflection.RuntimeModule.GetTypes(RuntimeModule module)
at System.Reflection.Assembly.GetTypes()
at DotNetNuke.DependencyInjection.Extensions.TypeExtensions.SafeGetTypes(Assembly assembly, ILog logger)
Prerequisites
- Access to the SQL Server and IIS.
Solution
The Digital Assets Manager has been replaced with the new Resources Manager to remove the Telerik dependency. This error is caused by DigitalAssetsPro library not being fully removed during the upgrade.
This issue can be resolved by removing the library manually. We advise making a full site and database backup before proceeding with the manual removal:
- Run the following query:
DELETE FROM Packages WHERE Name = 'DigitalAssetsManagementPro';
- Delete the <Site Directory>\DesktopModules\DigitalAssets folder
- Remove the DotNetNuke.Professional.DigitalAssets.dll file from <Site Directory>\bin
- Search your web config for
<add name="OpenFromServer" type="DotNetNuke.Professional.DigitalAssets.Components.HttpModules.OpenFromServerModule, DotNetNuke.Professional.DigitalAssets" />
and remove this line if present - Go to Internet Information Systems (IIS) and expand your server > Application Pools > Click on your application pool > Click Recycle.
Comments
1 comment
Thank you! This fixed my issue.
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